Instead of think about ZF2 || Symfony 2 think about ZF2 && Symfony 2

… if you want to use a good Symfony 2 bundle in ZF2 or a good ZF2 module in Symfony2
Symfony2 in ZF2

https://speakerdeck.com/skoop/zend-framework-2-and-symfony2-the-perfect-team-phpday-2013

https://speakerd.s3.amazonaws.com/presentations/7ac72050a1d901304c7f227bb3c2be12/ZF2_and_Symfony2_phpday.pdf

Symfony2 in ZF2
{
“require”: {
“php”: “>=5.3.3”,
“zendframework/zendframework”: “2.0.*”,
“symfony/yaml”: “2.2.*”,
“symfony/dom-crawler”: “2.2.*”,
},
“autoload”: {
“psr-0”: {
“Application”: “module/Application/src”
}
}
}

Notice: Attempting to quote a value without specific driver level support can introduce security vulnerabilities in a production environment.

“Notice: Attempting to quote a value without specific driver level support can introduce security vulnerabilities in a production environment.”

The notice appears if you print SQL query in ZF 2 : echo $sqlSelect->getSqlString();

Comment out and the notice disappears