Upgrading To Laravel 5.3.0 From 5.2

Upgrading To 5.3.0 From 5.2 : https://laravel.com/docs/5.3/upgrade#upgrade-5.3.0

Upgrade Laravel 5.2 to Laravel 5.3 : https://laravelshift.com/upgrade-laravel-5.2-to-laravel-5.3

Upgrading to laravel 5.3 from 5.2 – Laravel : https://www.livecoding.tv/lem93/videos/OreYp-upgrading-to-laravel-53-from-52

Error:

Declaration of App\Providers\EventServiceProvider::boot(Illuminate\Contracts\Events\Dispatcher $events) should be compatible with Illuminate\Foundation\Support\Providers\EventServiceProvider::boot()

https://laracasts.com/discuss/channels/forge/laravel-53-update-causing-error-on-forge-only

In App\Providers\RouteServiceProvider change the following:

OLD

public function boot(Router $router)
{
parent::boot($router);
}

NEW

public function boot()
{
parent::boot();
}

And change App\Providers\EventServiceProvider:

OLD:

public function boot(DispatcherContract $events)
{
parent::boot($events);
}

NEW:

public function boot()
{
parent::boot();
}

****

Trait ‘Illuminate\Foundation\Auth\Access\AuthorizesResources’ not found

Upgrade Guide said : The AuthorizesResources Trait

The AuthorizesResources trait has been merged with the AuthorizesRequests trait. You should remove the AuthorizesResources trait from your app/Http/Controllers/Controller.php file.

… and it is working.



and realised that you know that would be the last time they would...

Nick Cave - 20,000th day on the planet Earth

(Visited 614 times, 1 visits today)