Upgrade PHP from 5.3 to 5.4 on Ubuntu 12.04

I was deploying my Zend Framework 2 project when I got thios error:

Using $this when not in object context in /…./module/Webshop/Module.php on line …

“Upon googling, I found out that PHP 5.3 treats closures differently. This PHP version doesn’t support $this in closures.” (https://github.com/laravelbook/ardent/issues/23)

So I had to update from 5.3 to 5.4

sudo apt-get update
sudo apt-get install python-software-properties
sudo add-apt-repository ppa:ondrej/php5-oldstable 
sudo apt-get update
sudo apt-get install php5

http://running-on-drupal8.co.uk/node/17